4

I have a single record under a Custom Metadata Object. The object has a checkbox field, and in this one record I have that box checked to TRUE.

However, when I query the Custom Metadata Object, the query result shows that the field is FALSE.

Here's my setup, the only record in this object and it has the checkbox checked:

This is the single custom metadata record I have.  Note the checkbox is checked.

And then here's the result when I query this object: SOQL Query Result for the above record.

As you can see it's returning false for the field that I have set to true. The Record is set to "Protected Component = false", and the Object itself is set to Public, and the checkbox field is set to "Subscriber Editable".

I'm working in a packaging org trying to get this to work for a managed package. Any idea why it's returning the wrong value?

  • I also tried this in dev org. You are correct I am not able to get its value as true. I think here you need to raise case with salesforce. Please update same here if you get anything from salesforce. – Kiran Machhewar Dec 10 '15 at 16:53
3

So this is a bug/known issue found here: https://success.salesforce.com/issues_view?id=a1p300000008bS6AAI

The solution is to shorten the field's API name, which worked for me in this instance.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.