1

I'm trying to assign a profile to a user, this user is the "Automated Case User" and I'm getting this error:

Error: This user, as the Automated Case User, must have the "Modify All Data" and "Send Email" permissions. Select a profile or assign a permission set with these permissions enabled.

I've checked the Case object settings on the profile and it includes the "Modify All Data" I've also checked the Application Permissions and System settings and marked all the email related options.

Any idea why I'm getting this error?

  • Do you happen to have sharing enabled in your org? – crmprogdev Apr 5 '13 at 13:25
  • where do i check this? – Dedo Apr 5 '13 at 15:34
  • Click Your Name > Setup > Security Controls > Sharing Settings. A very good explanation of how sharing, profiles and roles all work together is included in Chapter 7 of the Force.com Plarform Fundamental Workbook. You might find some ideas there which might lead you to a solution to your problem. There's also a Sharing Cheatsheet you might find helpful to you and want to download. Both are free. – crmprogdev Apr 5 '13 at 16:31
  • In haring Settings, I have no custom Sharing Rules – Dedo Apr 6 '13 at 19:48
  • This is a security topic that may require help from an architect for your org. That said, here's two resources that may help: An Overview of Force.com Security which has a number of links at the bottom you may find of use and Designing Record Access for Enterprise Scale. – crmprogdev Apr 7 '13 at 14:51
2

You set the Automated Case User in the Case Settings, make sure the user you are trying to change the profile on is not designated there.

Setup > Customize > Cases > Support Settings > change the default.

You may also need to change the default lead user

Setup > Customize > Leads > Web-to-Lead

Hope this helps!

B

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.