0

I'm trying to edit the fields on my exisiting Outbound Message (contacts object), but I can't save it. It prompts me to correct errors. It doesn't recognize my 'required fields' which are populated. If I select Edit and then Save without any changes, It get the same message(s).

Error: Invalid Data. Review all error messages below to correct your data. You must enter a value

Managed - Beta This Workflow Outbound Message is managed, meaning that you may only edit certain attributes. Display More Information

I've been able to perform this task with other messages and objects without a problem. Thanks

1

The highlighting is wrong, but the error's correct-- you cannot edit a managed outbound message in an installed org. You'll have to correct your changes in the source org, upload a new beta version, uninstall the package from the installed org, and reinstall it into the target org.

5
  • sfdcfox, Thanks for the response. Actually, I wasn't clear. I am the developer, not the describer. The OB message I'm trying to modify 'is' in the source org. I welcome your thoughts.
    – Boots
    Dec 9 '15 at 5:14
  • Do I have to make it 'not' a part of the 'managed beta' in order to edit it? Reverse the process? If so, how? I welcome your thoughts.
    – Boots
    Dec 9 '15 at 5:21
  • If the component was protected, you'd have been able to modify it... So I presume you didn't protect it. You'll need to delete it and create a new one, I'm pretty sure. Make sure you make things like this protected in the future. You may need to contact support to enable deleting elements.
    – sfdcfox
    Dec 9 '15 at 12:15
  • The problem was that I had custom fields in the OB Msg. that had been removed from or renamed in the Object. Of course, the error message didn't identify that 'specifically'. So, I removed the fields and reloaded them again. Thanks for the help.
    – Boots
    Dec 9 '15 at 16:40
  • @S.Wong Good to know. You should probably write up your own answer, since that's what the problem was.
    – sfdcfox
    Dec 9 '15 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.