7

I wanted to create a chatter group for community Users and internal users should also be able to participate in the group. Not sure the correct procedure.

Does the Sys Admin need to create the group first? If yes, this is what I tried but could not find a way to add community users.

Can you please give some insight?

Thanks.

3 Answers 3

7

To create a community user Chatter group You need to create these group in community>first login into community as sys admin . then in chatter tab try to create groups for your community user and add them . It will solve the problem.

Also add your internal user profile as well as community user profiles in community user tab.

2
  • Thanks. I created chatter group by logging into community as sys admin but I can't see that group when I log in as regular sys admin.
    – sdondeti
    Commented Dec 8, 2015 at 17:28
  • @sdondeti I think you have create private group. Please add your user in that group and then they will be able to see that group. Commented Dec 9, 2015 at 4:59
5

There are a whole series of steps I needed to follow to finally get a Chatter group for both internal and external users. As an FYI, I am using a community portal with the Customer Account template.

  1. From the Builder, create an Object page for Groups. This creates a Group Detail page for your Chatter Group and a Group List, where you can create a new Chatter Group.
    Publish your changes.

  2. Logged into the Community as a system administrator, go to your new Group List and click "New" to create your new Chatter group. DON'T click "Allow customers" because you will just get an error. Choose whether it's private or public and save. (Do NOT create the group inside of the internal org.)

  3. In Workspaces, go to Administration and ensure the following:

    *On the Members tab, make sure both your internal & external user
    profiles or permission sets have been selected as members. (Remember that adding profiles as members will automatically send each person in that profile a welcome email, so disable the welcome email under "Emails" if that is not your intention right now.)

*Under Preferences, un-check "Show nicknames" if you want to be able to search for your Group members by name. Check "See other members of this community" and "Let guest users see other members of this community."

  1. Of course, make sure your users' profiles and permissions have access to Chatter, if they don't already.

  2. Logged into your Community as a system administrator, navigate to the Group Detail page for your new group and in the "Manage Members" section, add your internal and external users.

1
  • I have done step no:2 but when I tried to open that group as system admin mode getting this error Looks like there's a problem. Unfortunately, there was a problem. Please try again. If the problem continues, get in touch with your administrator with the error ID shown here and any other related details.
    – sai
    Commented Jun 5 at 14:16
1

I have found the answer atlast and I guess that is not possible to share chatter groups between internal users and community users.

Please refer to this idea on salesforce site

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .