When trying to override the new button for a custom object using URL to prepopulate fields, I need to use the ID of the field to prepopulate.

{!URLFOR($Action.ContactDetail__c.New, null, [Name='testname', 00H280000073992='test'])}

To avoid having problems if deployment is to be done in a new org (a new ID will be then assigned to the field, causing the URL formula to fail), I tried using a custom setting to sepcify the ID to use on the org level.

{!URLFOR($Action.ContactDetail__c.New, null, [Name='testname', $Setup.IdLabel__c.Test__c='test'])} 

($Setup.IdLabel__c.Test__c represents the custom setting field, and contains the value : 00H280000073992)

However I'm unable to make it work in the formula on the left side of the '=' (It works on the right side, but it's not the purpose of the formula. I need : FIELD_ID=VALUE, not the opposite : ...=FIELD_ID).

Can you help me ?


1 Answer 1


while I don't have a reason for the error you are getting, I tried few alternate options and ended up passing the Field Id and Value pair outside the URLFOR function by concatenating them like this

{!URLFOR($Action.ContactDetail__c.New, null, [Name='testname'])}&{!$Setup.IdLabel__c.Test__c}=test

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .