Became Hot Network Question
    Tweeted twitter.com/StackSalesforce/status/1187836549393727494
2 added 440 characters in body
source | link

I have the exact same component in 2 different sandboxes. The component uses lightning:recordEditForm and is passed an object name & Id. There is a lookup field to the Account object that is supposed to display as an output field in the form. I'm getting 2 different outcomes on page load..

Org A: When the component's recordEditForm loads, the Account loads and the __r related record also loads. I can see this by debugging the event params onload of the form, like this

enter image description here

Org B: The exact same component, in the exact same context, loads the Account field, but DOES NOT load the __r related record. So what I'm left with is a blank output on the Account field in the UI.

enter image description here

As you can see, the __r JSON does not load, so the form doesn't display the Account Name in the form.

I'm a sys admin in both orgs, with Modify All & CRUD access to Account object & the base object I'm working with - so it's not FLS or anything like that. Can anyone help explain why this would load in one context but not another?

EDIT for more context: Also in looking at what the recordEditForm is loading, I can see the objectInfos is not loading the Account object either..

Org A:

enter image description here

vs Org B:

enter image description here

Again - I have full read/write/modify all access to all objects & fields in both orgs...

I have the exact same component in 2 different sandboxes. The component uses lightning:recordEditForm and is passed an object name & Id. There is a lookup field to the Account object that is supposed to display as an output field in the form. I'm getting 2 different outcomes on page load..

Org A: When the component's recordEditForm loads, the Account loads and the __r related record also loads. I can see this by debugging the event params onload of the form, like this

enter image description here

Org B: The exact same component, in the exact same context, loads the Account field, but DOES NOT load the __r related record. So what I'm left with is a blank output on the Account field in the UI.

enter image description here

As you can see, the __r JSON does not load, so the form doesn't display the Account Name in the form.

I'm a sys admin in both orgs, with Modify All & CRUD access to Account object & the base object I'm working with - so it's not FLS or anything like that. Can anyone help explain why this would load in one context but not another?

I have the exact same component in 2 different sandboxes. The component uses lightning:recordEditForm and is passed an object name & Id. There is a lookup field to the Account object that is supposed to display as an output field in the form. I'm getting 2 different outcomes on page load..

Org A: When the component's recordEditForm loads, the Account loads and the __r related record also loads. I can see this by debugging the event params onload of the form, like this

enter image description here

Org B: The exact same component, in the exact same context, loads the Account field, but DOES NOT load the __r related record. So what I'm left with is a blank output on the Account field in the UI.

enter image description here

As you can see, the __r JSON does not load, so the form doesn't display the Account Name in the form.

I'm a sys admin in both orgs, with Modify All & CRUD access to Account object & the base object I'm working with - so it's not FLS or anything like that. Can anyone help explain why this would load in one context but not another?

EDIT for more context: Also in looking at what the recordEditForm is loading, I can see the objectInfos is not loading the Account object either..

Org A:

enter image description here

vs Org B:

enter image description here

Again - I have full read/write/modify all access to all objects & fields in both orgs...

1
source | link

recordEditForm not loading related record via lookup

I have the exact same component in 2 different sandboxes. The component uses lightning:recordEditForm and is passed an object name & Id. There is a lookup field to the Account object that is supposed to display as an output field in the form. I'm getting 2 different outcomes on page load..

Org A: When the component's recordEditForm loads, the Account loads and the __r related record also loads. I can see this by debugging the event params onload of the form, like this

enter image description here

Org B: The exact same component, in the exact same context, loads the Account field, but DOES NOT load the __r related record. So what I'm left with is a blank output on the Account field in the UI.

enter image description here

As you can see, the __r JSON does not load, so the form doesn't display the Account Name in the form.

I'm a sys admin in both orgs, with Modify All & CRUD access to Account object & the base object I'm working with - so it's not FLS or anything like that. Can anyone help explain why this would load in one context but not another?