Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

The Steps Followed to Get the Excel Connector working are as below:

[1] Installed Office Toolkit from the below Site: http://www.salesforce.com/us/developer/docs/office​toolkit30/SForce_Office_Toolkit_MSI.zip

[2] Downloaded the Excel Connector XLA from the below URL http://excel-connector.googlecode.com/files/sforce​_connector_901.zip.

[3] Excel >> Excel Options >> Add - Ins >> Manage (Excel Add - Ins) >> Browse >> Located the sforce_connect file (XLA file)

I was able to establish the Connection with my Sandbox by following the Steps...

In the Salesforce.com Login dialog Keyed in the below: User Name: Sandbox User Name Password: Password+Security Token Server URL: https://test.salesforce.com/services/Soap/c/16.0

And was able to connect....

I still have one issues while querying Custom Objects ....

Whenever a Query is initiated on a Custom Object, the criterion [System Modstamp > 1/26/2013] gets automatically added and the below error is thrown ... I also get a popup stating No Records returned.


Microsoft Excel

Error Generated by request::An internal server error has occured while processing your request. Url:https://cs8-api.salesforce.com/services/Soap/c/16.​0/00DL00000002wGB ExceptionCode : 5103


OK

Is there a solution to address the Error? ....

share|improve this question
    
If anyone is interested I have a solution much like the Excel Connector that will work with 32 and 64 bit OS and Office products. Currently I'm looking for qualified users to test it out. You can reach me at luhringsystems@live.com –  user3257 Jul 11 '13 at 0:48
    
I'm using the office toolkit 4.0 and excel connector 1603 version as well. It worked, then it didn't. Then it worked again and now it's broken again. Maybe I should start do a rain dance or another occult ritual to get it working.. –  Wouter Feb 24 at 15:07
add comment

2 Answers

Sorry - posted in the wrong place. As @eyescream says, you seem to have your versions all wrong...so make sure you have version 4.0 of the toolkit, and 1603 of the addin. There is also a little one stop script that installs both for you here:

I have also seen the 'Internal Server Error' start appearing recently when my query returns no data (instead of just a "no data found" message) - but you can just go ahead and modify your query as described above or in the help files and re-run and you should be fine...to test it is all working, just build a query for a record you know is in your system...

share|improve this answer
add comment

[2] Downloaded the Excel Connector XLA from the below URL http://excel-connector.googlecode.com/files/sforce​_connector_901.zip

This link doesn't work for me, 404 error. Try going to Downloads page and pick "1603". The new one (4 days old) for 64 bit machines is a bit quirky, my colleague tried it yesterday and it complained about office toolkit missing... Actually author admits it's untested ;)

This version is designed to work on 64 Bit OS/Office versions, i've not tested this but it's from a long time friend and so i'll post it and gather feedback in the issues area.

About the modstamp - it's standard thing, the tool tries to protect you from downloading all records which might mean thousands. Default is to retrieve records changed in last 7 days. You can easily bypass it:

  1. use the query wizard to build a WHERE clause, that way this standard one won't be appended. Or simply fill in the cells yourself in this format and then click "Query"

    object name | field name | operator | value | field name | operator | value
    
  2. You can also break the script execution (Ctrl + Pause/Break if I recall correctly), set the systemmodstamp value in the ancient past (2000?) and let it run query again ;)

  3. Try to examine the visual basic code and remove this default date-based constraint if it annoys you so much ;)

About the error message - it might be a broken/old library (seriously, what exactly have you downloaded?). Try enabling a debug log on the server side. Or maybe you got logged out? Does it appear after each action or only sometimes? Also - try bumping up the API version in the endpoint to 27, 16.0 is a bit old ;)

share|improve this answer
    
Thanks for the quick response ... basically I am looking at providing a way for the end users to Input data right from XLS into SFDC and seems some bit of tweaking is required before distributing the Add-In. –  sKaLiDhAsAn Feb 3 '13 at 14:06
    
Excel Connector is a crucial part of my life with SF, but letting end users use it to enter data? Scary. ;-) –  AMM Feb 7 '13 at 20:45
1  
Found an excellent subscription based tool from rssbus at rssbus.com/excel/?tabs=1 Might be useful for others looking for a stable tool to connect to Salesforce and perform CRUD, but again it is useful for the Admins. –  sKaLiDhAsAn Apr 21 '13 at 3:00
    
@SKALIDHASAN - this should be an answer, not a comment :) You can even accept it, it's perfectly OK to answer your own questions and ultimately you accept what was most useful for you. The link will be "lost" here (people with same problem might see the question but not your solution). And I'm happy you decided to come back to this question with the info about solution, a new tool I need to check out :) Plus by answering/accepting you'll improve site stats, 1 step closer to not being BETA :D –  eyescream Apr 21 '13 at 7:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.