Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

I read Woody Leonhard's article in InfoWorld on the dangers of Java yesterday, so I uninstalled the two JRE's on my Windows 7 computer, and then reinstalled the latest version.

This is what I have now:

C:\Users\David>java -version java version "1.7.0_11" Java(TM) SE Runtime Environment (build 1.7.0_11-b21) Java HotSpot(TM) Client VM (build 23.6-b04, mixed mode, sharing)

Then I tried to run the Force.com IDE, and it would not even start, complaining that it could not find Java.

So I removed all of the Force.com IDE, and tried a fresh install, using the 32-bit version installed by Pulse.

It went its merry way, but then it stopped as soon as it tried to start. I got the informative message JVM terminated. Exit code -1.

I found a note about changing a line in the forceide.ini

The factory version was:

utf8 (do not remove)

-startup ../Common/plugins/org.eclipse.equinox.launcher_1.0.200.v20090520.jar --launcher.library ../Common/plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519 -Xms40m -Xmx256m -install C:\Users\David\AppData\Local\salesforce.com\Force.com IDE -configuration C:\Users\David\AppData\Local\salesforce.com\Force.com IDE\configuration -vmargs -Dfile.encoding=UTF-8 -Xms256m -Xmx1024m -XX:PermSize=128M -XX:MaxPermSize=512M

I changed the last line to -XX:MaxPermSize=256M, and Eclipse started, sort of.

Now it hangs with the text on the left saying Eclipse Provisioning. But nothing with the Force.com IDE is there.

My Force.com IDE is loaded in c:\Users\David\AppsData\Local\Salesforce.com\force.com IDE.

My Java is loaded in c:\Program Files (x86)\Java\jre7\bin

Anyone have any ideas.

share|improve this question
add comment

5 Answers

Mark Pond is correct that you need to be running java 6 but you do not need to remove java 7 from your machine. Just download the java 6 JRE and add a line to the ini file to manually set your java VM. This way it won't get messed up again if you ever switch java versions on your machine.

Instructions on how to add -vm argument are here.

share|improve this answer
    
Very true that Java 7 doesn't need to be removed! I figured that it would simplify the troubleshooting of the issue if there was just a single JDK on the machine. –  Mark Pond Jan 16 '13 at 20:23
add comment

As requested by @MarkPond.

I am running Java 7 without any issues. My configuration is as follows:

  • Windows 7 64bit
  • jdk 7u11 64bit
  • force.com IDE 64bit (not eclipse + plugin)

I have not made any changes to the forceide.ini

The only thing I can offer is that I don't have java installed in Program Files, it's installed to C:\Java\jdk1.7.0_11 I have no idea if a path without spaces makes any difference, but it is an option.

I have seen this error before. My recommendation is uninstall everything java and the ide, then reinstall java first then the ide. And if that doesn't work start again and do as the other posters have suggested and use Java 6

share|improve this answer
add comment

You need to be running Java 6 (1.6)

So, remove Java 7 and install JDK 1.6 again. If you're running a 32-bit version of Eclipse be sure to download and install the 32-bit JDK.

share|improve this answer
    
Why? I am running the IDE with 7 just fine –  Daniel Blackhall Jan 17 '13 at 10:45
    
@DanielBlackhall Why? Because that is what worked for me when Java7 caused me to have a non-functional Eclipse installation which was previously working fine with only Java6 on the machine. It would be helpful for everyone if you could contribute to the conversation with your configuration of Java6 & Java7 and Eclipse with the unique .ini values you found to work. –  Mark Pond Jan 17 '13 at 17:24
add comment

I was also faced the same problem and i got the solutions by doing following editing on
forceide.ini

-startup
plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.1.R36x_v20100810
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vm
C:/Program Files/Java/jdk1.7.0_04/bin/javaw.exe
-vmargs
-XX:MaxPermSize=256m
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx384m

share|improve this answer
add comment

I had a similar problem on Mac OS X 10.6.8 -- I already had the IDE installed and everything was working fine until one day I started getting the JVM terminated. Exit code -1 error

Running the IDE from the command line:

<install dir>/Force.com IDE.app/Contents/Profile/forceide.app/Contents/MacOS/foreceide

gave

Error occurred during initialization of VM
Could not reserve enough space for object heap

even though the machine had plenty of RAM available and regular Eclipse runs fine.

The solution was to edit the -Xmx setting in forceide.ini (thanks @AxaykumarVaru for pointing me in the right direction). Max value that worked was -Xmx512m. I left all the other settings at their defaults.

For the sake of completeness here is my entire working forceide.ini:

#ansi (do not remove)
-startup
../../../../../../Common/plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
--launcher.library
../../../../../../Common/plugins/org.eclipse.equinox.launcher.carbon.macosx_1.0.200.v20090520-1835
-install
/Developer/salesforce.com/Force.com IDE.app/Contents/Profile
-configuration
/Developer/salesforce.com/Force.com IDE.app/Contents/Profile/configuration
-vmargs
-Dfile.encoding=UTF-8
-Xms256m
-Xmx512m
-XX:PermSize=128M
-XX:MaxPermSize=512M
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.