Sign up ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

I set up salesforce sites to work with our customer portal and added a custom domain name to it but for some reason in any browser that I am logged in to salesforce the domain name just redirects to the default salesforce login screen.

But if i open the same domain name in an incogneto window it opens the portal just fine?

The domain is, a related problem is also that never works?

the cname is set up and working? any ideas?

share|improve this question
So in incognito, when you enter you get the correct behavior? Have you tried using a tool like Fiddler to see what is going on? – Mike Chale Jan 7 '13 at 15:56
yea i see the site just fine at and at but not is there a way to get it working with both www and without – Keith Mancuso Jan 7 '13 at 16:22
1 is for a product called My Domain, not Sites. – Ryan Guest Jan 7 '13 at 17:19

3 Answers 3

up vote 3 down vote accepted

You need to save the value ( into the Custom Web Address field on the Site. (Setup -> Develop -> Sites -> [Site Name] -> Edit) will never work because salesforce/DNS does officially not support CNAME records at the root (naked) domain level.. You will need to setup a redirect from to with your DNS provider.

share|improve this answer

Here may be solution, I faced the same problem but I was trying to setup it in sandbox environment. This says 'Custom Web addresses are not supported for sandbox or Developer Edition organizations.' Hope, this helps.

share|improve this answer

This is a DNS problem on the domain.

Check and correct the DNS entry for the www CNAME record or the 'website redirection'-type feature if you are using one. This isn't a SalesForce issue.

One preemptive strike item to be aware of is that your site will generate an SSL Certificate name mismatch at:

you would see this mismatch after a user logs in to the Customer Portal and is using a secure session and you direct them to the vanity URL over SSL. It will however work correctly at the default address:

If you need to maintain the custom domain name while on SSL, building a reverse-proxy is the easiest manner to achieve it (easy being a relative term).

share|improve this answer
thanks for the help. www has a cname for, is that not correct? should the cname be for i was playing with the sites settings and tried it set up both with and without the www but couldnt get both to work – Keith Mancuso Jan 8 '13 at 5:56
as for the ssl, I didnt think you could get ssl to work with sites? I would love for it to work but can you point me to how to get the reverse-proxy setup? – Keith Mancuso Jan 8 '13 at 5:58
SalesForce is hosting a wildcard certificate for the * domain which allows for SSL on any of the domains. SalesForce doesn't host customer SSL certificates because of the added maintenance effort and the requirement for a dedicated IP address allocated to the certificate. It is possible to have it done if you are providing sufficient revenue making it cost effective to justify the effort & ongoing maintenance. A reverse proxy is usually your own external Apache server running the mod_proxy modules and hosting the SSL cert, becoming a middle-man for your SFDC site traffic. – Mark Pond Jan 8 '13 at 7:40
As @Ryan mentioned in another answer, a CNAME record per the DNS spec isn't valid at the root of the domain. (Valid: CNAME Invalid: CNAME So, by this logic, your CNAME should be on the www host entry. If you also need the root address to redirect users to the www host, name registrars typically offer this as a feature that you can enable. GoDaddy DNS Forwarding – Mark Pond Jan 8 '13 at 8:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.