Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

I am unable to save csv file only in IE8. Can any one help me with this? I am getting an error that says "the site that you requested is either unavailable....". It is working fine in all other browsers and even in IE9. I have kept cache="true" also..

Here's what my Visualforce page looks like:

<apex:page controller="XXX" extensions="YYY" wizard="true" showHeader="false"
cache="true" contentType="application/vnd.ms-excel#{!accountName}docs">
share|improve this question
    
Can you post some of the VF page code? Especially the page tag? –  joshbirk Jan 3 '13 at 21:17
    
Please check the page code Bellow: –  Haritha Jan 3 '13 at 21:20
    
<apex:page controller="XXX" extensions="YYY" wizard="true" showHeader="false" cache="true" contentType="application/vnd.ms-excel#{!accountName}docs"> –  Haritha Jan 3 '13 at 21:20
1  
Similar question here: salesforce.stackexchange.com/questions/3781/… –  Peter Knolle Jan 3 '13 at 22:56
    
If the link posted by Peter above does not work for you, it could just be the settings in your IE8 browser(One of the worst for today's standards BTW).Try to uncheck the “Do not save encrypted pages to disk” option in the advanced internet options. –  Richard N Mar 4 '13 at 22:42
add comment

1 Answer 1

Two things come to mind:

  1. Try turning cache to False, at least to test if that has any root cause.

  2. Try adding an extension to the filename, since it is IE we're talking about. So contentType="application/vnd.ms-excel#{!accountName}docs.csv" might be more effective.

share|improve this answer
    
I tried both the options. still the same behaviour. but this is only happening when i login to portal and progress through. it is working fine if i do it through developer mode. and when i login to portal my site pages will be on https and we have some authentication mechanism to acess the page –  Haritha Jan 3 '13 at 21:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.