Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

I have tried to delete fields on objects such as Opportunities, as Salesforce has supposedly made it possible to do so in Schema Builder, but when I right click on the field and select 'delete' it doesn't remove it. I've tried all the major browser, so it doesn't appear to be a browser support issue.

fyi: these are also custom fields, that I'm able to delete in the settings panel, just thought it would make quicker work of it in schema builder.

share|improve this question
1  
I tested in my DE org and I can't delete fields either. Clicking on the Delete Field... button doesn't display a pop up confirmation. You should open a case with Salesforce for this bug. –  Daniel Hoechst Dec 21 '12 at 20:12
1  
I agree with you @DanielHoechst. When I click the Delete Field... button on a custom object's field I do see the delete confirmation and I see HTTP post with a param of action=FetchFieldDeleteMessage (and other params). However, when I tried to delete a custom field on an Account I observed the same thing as you and didn't see any HTTP requests go out, so it looks like a bug. –  Peter Knolle Dec 22 '12 at 0:38
    
Thanks for the suggestion @DanielHoechst, I've entered a case through salesforce help and contact support. I'll followup with any new developments, maybe there is a fix in Spring 13, but I did a search on 'Known Issues' and nothing seems to come up under scheme builder. –  Miklr Jan 2 '13 at 20:48
add comment

1 Answer

up vote 2 down vote accepted

The following is the latest response from SF tech support...

I understand that you have refreshed your SB, I was able to easily reproduce this issue in my demo production org, this is actually part of a known issue and R & D have logged a bug for this to be fixed in the next major release summer 13.

Apparently the bug can only be isolated to deleting custom fields on "Standard Objects" and NOT on Custom Objects, you would not see the same issue when trying to delete custom fields on custom objects.

That being said, please let me know if it would be ok to move this case to the next status of bug fix submitted so that R & D are aware that you are affected by this issue.

Workaround: continue to use the legacy route in deleting customer fields

Setup>Standard Object>Fields>Custom Fields>Delete.

Please let me know if you have any questions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.