Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

Force.com Migration Tool:

I am trying to install Force.com Migration tool which runs based on JDK & ANT.

I have successfully installed JDK1.6 & set an environment variable. as described in the tutorial, I see the successful response in the console for Java -Version.

C:\Users\PRAX>java -version java version "1.6.0_38" Java(TM) SE Runtime Environment (build 1.6.0_38-b05) Java HotSpot(TM) 64-Bit Server VM (build 20.13-b02, mixed mode)

I have tried installing Ant as well. I have downloaded ant package from http://ant.apache.org/bindownload.cgi unzipped the content. tried to set the environment variable under the name "ANT_HOME". it din work. I tried executing, SET ANT_HOME = installation path --> ran in cmd prompt. it worked. I checked by echoing it "echo %ANT_HOME%", it has fetched the correct path.

but, when I execute "ant" in cmd.. i don see any result.

C:\Users\PRAX>ant 'ant' is not recognized as an internal or external command, operable program or batch file.

can someone please explain how to set path or variable to make Migration tool work on my computer?

Thanks!

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

You also new to add the Ant bin folder to your PATH environment variable in windows.

So Computer > Properties > Advanced > Environment Variables

You will find a variable called PATH. Append your ant bin directory to this variable.

Launch a new command window and then try.

I had answered this in more detail here, have a look it should sort you out hopefully.

The term 'ant' is not recognized as the name of a cmdlet, function, script file , or operable program

share|improve this answer
    
Hi @Techtrekker, this time I followed the procedure you have put up. it worked fine. Thanks a lot for that. but, when I check the "ant" in the cmd prompt.. I see this result.C:\Users\PRAX>ant -version Unable to locate tools.jar. Expected to find it in C:\Program Files\Java\jre6\li b\tools.jar Apache Ant(TM) version 1.8.4 compiled on May 22 2012 some warning: "unable to locate".. would it affect application while using? –  PraveenMakam Dec 20 '12 at 10:09
    
That seems like a java jre lib setup thing. Have you also copied the salesforce migration jar to your ant lib directory? –  techtrekker Dec 20 '12 at 14:35
    
yes, I did.. its working fine now. Thanks again. –  PraveenMakam Dec 26 '12 at 5:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.