Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

My URL :- http://myurl.com/homepage2 This is a site URL... I am showing a page if user will fire this URL..

While running this URL i am getting some permission problem --

What i have tried -- Try to modified profile setting for assigning permission set and all.. But no use.

I followed some documentation for visual force.. But unable to figure out.

share|improve this question
    
Is this page displaying data from Salesforce? Have you checked that the site guest user has access to all sobjects and fields? –  Bob Buzzard Dec 20 '12 at 8:11
    
@BobBuzzard I am not getting this options... While checking I am unable to check site guest user access.. –  Learner Dec 20 '12 at 9:11
2  
The site guest user = public access settings. Check the settings to make sure the profile has access to all the required data. You could also try clicking the 'preview as admin' for the site and navigating to that page - often that allows you to see the underlying error. –  Bob Buzzard Dec 20 '12 at 9:12
1  
If you go to Setup > Monitoring > Debug Logs and create a new monitor on your site guest user is there anything amiss after viewing the page again? –  user320 Jan 23 '13 at 9:31

2 Answers 2

up vote 2 down vote accepted

I have a lot of experience with this, and can probably help you.

Can you go to sites and get the name and URL of the site? Often, unless your site is the "root", the URL needs to be URL/sitename/pagename and URL/pagename will give you that error.

As far as debugging sites, there's a good question about that

Often, you can get this page if there's a visualforce error of some sort (unhandled exception) because sites permissions don't let force.com share that error with guests so you get the awful progression of your page>error page>auth error.

So use the debug trail to find out what's happening.

share|improve this answer
    
Thanks for you help !! –  Learner Jan 23 '13 at 9:27

In the configuration of your Site (setup>app setup> develop > sites), the page should be added to the Site Visualforce pages if you want to access it as a guest user.

Clicking the public access button will allow you to set the guest profile settings, i'm not sure if you can do that through permission sets. Pages you add to the Site Visualforce pages will already be added to the profile.

share|improve this answer
    
I clicked on public access setting and I checked for visualforce page access.. But its not working for me.. –  Learner Dec 20 '12 at 7:47
    
I checked on user it is site guest user ... –  Learner Dec 20 '12 at 7:56
    
thanks for your answer !! –  Learner Jan 23 '13 at 9:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.