Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

I am passing Id's as pipe seperated params in URL and want to pass the params to salesforce reports e.g String param_ID_url = '701K00000002MtxIAE|701K00000002Mz9IAE';

when I try to pass to the button using Action global variable the url gets encoded and shows up as : 701K00000002MtxIAE%7C701K00000002Mz9IAE

Is there any way to stop this and let the | be as | symbol in the URL. I tried using substitute in the button code to substitute '%7c' with '|' still no lucj :(

Please guide me on how to make the | pass as pipe than encoding to %7c

button code:

https://www.appextremes.com/apps/Conga/Composer.aspx?
SessionId={!$Api.Session_ID}
&ServerUrl={!$Api.Partner_Server_URL_210}
&id={!Campaign.Id}
&TemplateId=a25K0000000D6wF
&FP0=1
&ReportId=00OK0000000FaWF?**pv0={!substitute(String param_ID_url,'%7c','|') }**
&DS7=0
&OCNR=1
share|improve this question
    
I don't think you can change the URL encoding to use your pipe, as that's done on server side. Adjust your code on the other side to split the Id's based on the encoded delimiter (%7C) –  Bachovski Nov 16 '12 at 2:27
    
I am passing the ID to the report :( so i cannot seperate it :( –  rao Nov 16 '12 at 2:28
    
Are you sure you can pass multiple ID's in a single query? –  Bachovski Nov 16 '12 at 2:35
1  
I think they need to be comma separated rather than pipe as per this example : acertiscloud.screenstepslive.com/s/manuals/m/invoice_it/l/… –  Bachovski Nov 16 '12 at 2:40
2  
You can't pass pipes in a URL as it will be encoded before passing it through. For multiple params to a report , use ?pv0=value1&pv1=value2 –  techtrekker Nov 16 '12 at 2:45

1 Answer 1

As shown on this tutorial:

http://acertiscloud.screenstepslive.com/s/manuals/m/invoice_it/l/80749-how-to-configure-conga-composer

your Id's should be comma separated as oppose to pipe.

share|improve this answer
    
comma seperated on pv0 params will break the reports as 2 reports and still will not pass the second id to the report. I teste this the only place where i am struck is the urlencode:( on pipe –  rao Nov 16 '12 at 2:46
    
Well I don't think you can do much there unfortunately –  Bachovski Nov 16 '12 at 2:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.