Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

So I have a VF page with Streaming API and it's working fine in me because I'm the System Administrator. Now I'm testing out as another user with different profile, and the Streaming API is not working for this user.

This is what I enabled In user's Profile:

Object
PushTopic
Read  -  true

And also The Custom Object I'm Streaming

Enable Streaming API - true

And of course I enabled the Streaming API for my ORGANISATION.

Did I miss something?

share|improve this question
2  
Does the other user's profile has access to the object that you're subscribing to? Also check the field level security for the fields that you're listening for a change –  Bachovski Jul 22 at 1:46
    
Ok I'll try what you've said. –  mdechavez Jul 22 at 1:48
    
Oh great!! A lot of thanks to you!!! I'm ashamed that I didn't check that before asking questions here. –  mdechavez Jul 22 at 1:57
    
can you post your comment as an answer, so i can mark it as answer to my question. Thanks again @Bachovski –  mdechavez Jul 22 at 1:58

1 Answer 1

up vote 3 down vote accepted

It's most likely the field level security for the fields that you're listening for a change or permissions for the object that you're subscribing for in your query for that particular user's profile.

These are the things you should look out for every time you experience an issue when switching between profiles.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.