Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

I have recently began using MavensMate and I'm running into a problem where every time I save I have to refresh the metadata container. I have read through the documentation, but haven't been able to locate a solution in the documentation. The error I get is

Result: [OPERATION FAILED]: Resource  Not Found. Response content: [{u'errorCode': u'NOT_FOUND', u'message': u'Provided external ID field does not exist or is not accessible: <unknown>'}]

Again my only solution I have found so far was to refresh the metadata container after every time I save. Is there something I need to set inside the of the settings?

share|improve this question
    
I'm assuming this is a Summer 14 Org, correct? –  Daniel Ballinger Jun 10 at 23:46
    
Yup it sure is @DanielBallinger –  EricSSH Jun 10 at 23:47
    
Did you check the API version of the file you're attempting to save? We saw an instance where one was set to API version 31 for some reason. –  Phil B Jun 11 at 21:16

2 Answers 2

up vote 14 down vote accepted

Fixed by setting mm_compile_with_tooling_api = false;

There is currently an open issue for this in the MavensMate Github : Error saving files to sandbox with Summer'14

share|improve this answer
    
My colleague was experiencing the same issue yesterday all day. Disabling the tooling API is not a resolution though :) –  Bachovski Jun 10 at 23:19
2  
It may not be, but its allowing me to actually get some work done :) –  EricSSH Jun 10 at 23:24
    
Thanks Daniel, hopefully this will help out some people –  EricSSH Jun 10 at 23:46
    
I work with the tooling API disabled regularly due to some issues with the compiler the tooling API uses and haven't had much issue. Slightly slower, but certainly still a good tool. –  ca_peterson Jun 11 at 4:26
1  
patch is available for that now, see github.com/joeferraro/MavensMate/issues/290 for discussion, patch github.com/joeferraro/mm/pull/25 –  Ralph Jun 26 at 18:15

In a nutshell, the tooling api documentation is extraordinarily basic, and doesn't cover response formats and a lot of expected behavior. So people try and guess stuff, and no surprise Salesforce changes stuff, again without documentation or notice.

There is a very extended discussion on github. At a high level, when updating an metadata member, you have to PATCH or POST depending on whether it's new to the metadata container. The current algorithm MM was using was to try post, and if it fails, pull out the correct id from the response and do a PATCH. With Summer '14 the POST response boofed and just returned

Old Response (with a totallly fake id)

[
  {
    "errorCode": "DUPLICATE_VALUE",
    "fields": [],
    "message": "duplicate value found: 400asdfasdfasdf1 duplicates value on record with id: 400asdfasdfasdf1"
  }
]

New Response

[
  {
    "errorCode": "DUPLICATE_VALUE",
    "fields": [],
    "message": "duplicate value found: <unknown> duplicates value on record with id: <unknown>"
  }
]

A patch is available, but hasn't yet been merged by the mm project collabators.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.