Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

I am getting the following issue while trying to install Mavensmate in my Windows 7 ultimate.

Installation of sublime text plugin failed.

Image

share|improve this question
1  
So are you inside company firewall?Come out of your VPN and Install.This is due to your network proxy blocking installation –  Mohith Shrivastava Apr 30 at 11:23

4 Answers 4

up vote 7 down vote accepted

Techman97 just posted an excellent walkthrough on his blog:

http://techman97.wordpress.com/2014/03/11/installing-mavensmate-on-win7-64bit/

I suspect that, given your issue, you're dealing with one of two situations:

  1. You're behind a firewall. Your options are ... get out from under the oppressive firewall! Protest! yell Attica! Attica! until your IT dept has turned off the firewall. Then use the pitchforks and torches you've magically acquired to show them to the door.
  2. You have git mis-installed or there is a ssh key issue going on. You can identify which, by setting up your own github account, and using git via ssh to push a commit to any repo. Then, retry.
share|improve this answer
    
This is a good tutorial but he doesn't address this issue in his blog. –  EricSSH Jun 10 at 17:46

Open command line and try out the git command. If it doesn't work - you'll have to install Git. The Mavensmate installation walkthrough uses some vanilla Git, I've had the one from Github installed already but the command didn't work for me either.

I think you could try starting the setup from the Git's (or should I say Github's?) power shell where the command works OK... But I've simply added git.exe to my environment PATH variable (I'm on Windows 8, I've typed "edit the system environment variables" in the Start menu - you might have to Google a bit how to do it on your Windows).

I've added this at the end of the current PATH (semicolon is important)

;C:\Users\(your user)\AppData\Local\GitHub\PortableGit_(something random here)\bin

Then I've closed the old Command Prompt and opened new one (this should make the new env. variables visible, you can verify it by typing path command). Try out git again and the installation should work.

Hm... actually probably you could modify the path variable just in this cmd session without adding git permanently to the path if you're not going to use it further...

Anyway - that solved it for me. I've found that blog post from @KevinP's answer useful too and I've ended up with 2 SSH keys (1 generated by Github's client, 1 generated manually)... No idea if you really have to follow this manual key generation but this answer helped me to reach a solution so +1 :)


P.S. In case you will have to generate the SSH keys by hand...

https://help.github.com/articles/generating-ssh-keys is a good start but it's still very Linux/Unix centric. (Well, OK, they probably assume you're in the PowerShell where all these fancy commands actually work). You'll have to translate them a bit:

   They write              They mean
1. ls -al                  dir
2. eval `ssh-agent -s`     ssh-agent -s
3. ssh-add ~/.ssh/id_rsa   ssh-add id-rsa

#2 I don't know much about *nix, I think it'll spawn the process in new shell? We don't really care...

Maybe just really install Git from GitHub :) It will come with power shell and / or you'll be able to generate this with clicks in the settings...

enter image description here

share|improve this answer
    
Nice answer eyescream. Upvoted... –  Baskaran S Jun 24 at 19:45
    
I'm bit puzzled about this SSH stuff because I was under impression you need it only to start contributing something, not to simply download files from GitHub. They have this concept of anonymous download of zip files after all or the svn checkout... –  eyescream Jun 24 at 20:10

There is a git command line on global config to have it not check SSL. ( sslnoverify).

You can temporarily do that to get your install done.

share|improve this answer

Launch a shell

cd "C:\Users\yourUserName\AppData\Roaming\Sublime Text 3\Packages"

do thiss

git clone --recursive http://github.com/joeferraro/MavensMate-SublimeText.git MavensMate cd MavensMate git submodule init git submodule update

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.