Take the 2-minute tour ×
Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. It's 100% free, no registration required.

Does anyone know any reason an error could occur if I do not download version 1.1 of a package before version 1.2. Some functionality don't work unless I install version 1.1 before 1.2. I cannot download 1.2 directly and skip over 1.1, although there are no new fields, objects etc added in 1.2. Just some small changes in its controllers code and its corresponding visual force page. Is it a salesforce problem?

share|improve this question
1  
What is the package? Does it have an OnInstall code? If so, contact the vendor and sort it out with them. –  DavidSchach Apr 21 at 20:26
    
Hey, it is a package that my friends company made, I have been working on it a bit too. It does have an oninstall code. Could that be causing issues? –  ths Apr 21 at 21:36

1 Answer 1

up vote 6 down vote accepted

From the comments, it seems that your package has OnInstall code - and that code assumes that upgrades are done sequentially without skipping any steps.

The code should be rewritten to perform all steps, in order, required for every version since the previously-installed version. For instance, if installing 1.2 on top of 1.0, the code should execute all steps for 1.1 and 1.2.

share|improve this answer
    
More complete answer: The OnInstall code "knows" the previous version and the version-being-installed, so it can execute only the required steps. In other words, if installing 1.2 over 1.1, it wouldn't need to execute the step for installing 1.1 over 1.0. –  DavidSchach Apr 23 at 17:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.