Salesforce Stack Exchange is a question and answer site for Salesforce administrators, implementation experts, developers and anybody in-between. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Already in remote site settings the remote site url is "http://b345616rdm.th2.sony.fr:6600".. But when I tried to change it as " http://b345616rdm.th2.sony.fr:6600/web_dat_2_1/GetValidData" , it is not getting pasted fully. Again its showing the prev one. But it got saved successfully.

Can anyone please tell me how to resolve this ?

share|improve this question
    
Remote site setting save base url . so it will work for you. – Tushar Sharma Jan 5 at 5:24
    
cant get you !! please be more specific – user27537 Jan 5 at 5:29

Remote SIte URL just store the protocol + sub domain name + domain name + port number and ignore anything after /

for example if you enter:

https://www.runscope.com/alerts/j0peqpwtrzd7

It will only take https://www.runscope.com

That is how it works.

Once the base URL is added you can request any resource on that server.

share|improve this answer
    
thanks a ton !! – user27537 Jan 5 at 5:41

In Salesforce Remote site setting only save the base url because in this way it will handle multiple urls.

For example:

xyz.com/abc
xyz.com/jkl

Now remote site setting only save xyz.com . But it can handle both URLs a same time.

share|improve this answer
    
thanks a ton !! – user27537 Jan 5 at 5:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.